What are the prerequisites for use of the Mercedes me Adapter?
What are the prerequisites for use of the Mercedes me Adapter?






















Ligtbox Caption Text
Answer Text

The requirements for using the Mercedes me Adapter are as follows:

  • A compatible smartphone (see "Adapter App" section) with iOS 10 / Android 5 or later operating system

  • A Mercedes-Benz vehicle from one of the compatible model series and production periods

  • The Mercedes me Adapter App (available free of charge from the Apple App Store or Google Play)

  • A Mercedes me user account (register at www.mercedes.me) for which the Terms of Use have been accepted

  • Mercedes me Adapter (exclusively available from your Authorised Mercedes-Benz Retailer)

Youtube Video ID
Button type standard
Primary Button Text Primary Button Target
Secondary Button Text Secondary Button Target
Additional answer Text